BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 5-Series (G30) Forum 2017+ BMW 5 Series (G30) General Discussions 2019 530e with CEL and bad temp sensor...

Post Reply
 
Thread Tools Search this Thread
      08-05-2019, 04:42 PM   #1
geneatals
Ninja
geneatals's Avatar
United_States
347
Rep
4,000
Posts

Drives: 2019 530e
Join Date: Dec 2007
Location: So Cal (SFV)

iTrader: (3)

2019 530e with CEL and bad temp sensor...

Hi all,

Just wanted to share my current experience with my 2019 530e. Picked up the car almost 1 year ago (10/2019), yesterday was driving and got a CEL. I'm due for an oil change anyway, brought the car into the dealership today, reported back I have a bad temp sensor that needs replacing. Don't have the part in today, so bringing it back in tomorrow.

Not sure if this is isolated or something common with this make model, regardless figured I'd post about it...

Did not experience any abnormal car behavior prior to the CEL. It has been hot out here in So Cal the last week or so and my car was sitting in the garage all last week as I was out of town (which threw my TPMS off, got that sorted yesterday also).......that's all I got...
__________________
2019 AW G30 530e l ZPP l ZMP l ZDH
Appreciate 0
      08-05-2019, 04:56 PM   #2
SteveinArizona
Colonel
United_States
1905
Rep
2,741
Posts

Drives: BMW 530e
Join Date: Jul 2016
Location: Greater Phoenix

iTrader: (0)

Mine is now a year and a half old and I have not had any problems and the temperature here in Scottsdale is a lot hotter than So Cal.

In my prior "e" (330e) I had constant CELs...all involving the battery pack. Eventually they replaced the entire battery pack but by that time I was so frustrated that I sold it back to BMW as a quasi lemon.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:03 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST