BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 5-Series (G30) Forum iDrive, Audio, Bluetooth, Phone, Cameras, Electronics + Coding Apple CarPlay Problems

Post Reply
 
Thread Tools Search this Thread
      10-12-2018, 03:36 PM   #1
ChristianC
New Member
United_States
0
Rep
21
Posts

Drives: 2018 BMW 530i
Join Date: Sep 2018
Location: San Antonio, TX

iTrader: (0)

Apple CarPlay Problems

Recently purchased Apple CarPlay for my 2018 530i. Every day since I've purchased I have had problems. The Apple CarPlay disconnects from the car and reverts back to the phone while driving then tries to reconnects multiple times. The best advice given by the BMW Genius phone advising was "disconnect your device and reconnect it" With this done I'm still having the same problems. Phone calls revert back to my iPhone as well as music. Not sure what the solution would be?
Thanks in advance.
Appreciate 0
      10-12-2018, 04:48 PM   #2
ADS-UK
Captain
ADS-UK's Avatar
United Kingdom
445
Rep
978
Posts

Drives: G30 - 530d M Sport
Join Date: Feb 2014
Location: Edinburgh, Scotland

iTrader: (0)

Garage List
Quote:
Originally Posted by ChristianC View Post
Recently purchased Apple CarPlay for my 2018 530i. Every day since I've purchased I have had problems. The Apple CarPlay disconnects from the car and reverts back to the phone while driving then tries to reconnects multiple times. The best advice given by the BMW Genius phone advising was "disconnect your device and reconnect it" With this done I'm still having the same problems. Phone calls revert back to my iPhone as well as music. Not sure what the solution would be?
Thanks in advance.
Have you tried removing the connection from the car and phone? Sometimes these issues can be solved via that.

Other thing to try is to restore the phone. Besides that I'm not sure what else you could try.
Appreciate 1
      10-12-2018, 10:20 PM   #3
ksoze
Major
ksoze's Avatar
United_States
313
Rep
1,123
Posts

Drives: 2018 M550iX
Join Date: Nov 2010
Location: Maryland

iTrader: (0)

I have also had similar performance with CP. Using an iPhone X with 12.1

My interest in CP was more in Tidal and now Waze and G Maps, but it has had similar connection issues and have recently reverted to using the iDrive phone connection and my USB SSD for lossless music.
__________________
2018 M550iX-Dinan Stage 1 | 2011 E93 M3 Convertible | 2002 E46 M3 Convertible | 2002 E53 X5 3.0 | 2000 E39 540i | 1998 E36 M3 | 1988 E28 M5 | 1987 E28 528i
Appreciate 1
      10-14-2018, 04:47 PM   #4
ChristianC
New Member
United_States
0
Rep
21
Posts

Drives: 2018 BMW 530i
Join Date: Sep 2018
Location: San Antonio, TX

iTrader: (0)

Quote:
Originally Posted by ADS-UK View Post
Quote:
Originally Posted by ChristianC View Post
Recently purchased Apple CarPlay for my 2018 530i. Every day since I've purchased I have had problems. The Apple CarPlay disconnects from the car and reverts back to the phone while driving then tries to reconnects multiple times. The best advice given by the BMW Genius phone advising was "disconnect your device and reconnect it" With this done I'm still having the same problems. Phone calls revert back to my iPhone as well as music. Not sure what the solution would be?
Thanks in advance.
Have you tried removing the connection from the car and phone? Sometimes these issues can be solved via that.

Other thing to try is to restore the phone. Besides that I'm not sure what else you could try.
Deleted the phone from the IDrive system, as well as deleted all CarPlay systems from the phone. Updated phone to newest version and reconnected the phone to the IDrive, we shall see how well it does from here out.
Thank you for the advice.
Appreciate 0
      10-14-2018, 04:49 PM   #5
ChristianC
New Member
United_States
0
Rep
21
Posts

Drives: 2018 BMW 530i
Join Date: Sep 2018
Location: San Antonio, TX

iTrader: (0)

Quote:
Originally Posted by ksoze View Post
I have also had similar performance with CP. Using an iPhone X with 12.1

My interest in CP was more in Tidal and now Waze and G Maps, but it has had similar connection issues and have recently reverted to using the iDrive phone connection and my USB SSD for lossless music.
Updated the phone, deleted CarPlay from everywhere on the phone as well as deleted the phone from the IDrive. Reconnected and will see how well this does over my next few drives.
Appreciate 0
      10-16-2018, 02:58 AM   #6
Almaretto
Major General
Almaretto's Avatar
United_States
1872
Rep
7,751
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Ask BMW to update Software.
Appreciate 0
      08-14-2019, 03:30 PM   #7
Damo Engelbrecht
Registered
0
Rep
2
Posts

Drives: BMW 530e 2017 G30
Join Date: Aug 2019
Location: Ireland

iTrader: (0)

CarPlay Audio out of Sync

Hi there, I wonder if anyone can assist or point me to the correct forum?

I am having audio latency issues when playing YouTube videos or any videos for that matter through CarPlay. Video plays on iPhone and audio through CarPlay however it is out of sync by a good few seconds. I think it has to do with the fact that the CarPlay connects wirelessly?

Can I change from wireless CarPlay to the lighting cable through USB as this might resolve the lag. Or is there a app or tweak anyone is aware of that can adjust the frame rate in YouTube or adjust the audio timing?

Have anyone heard of this before? If so, any suggestions?

Thanks Damo
Appreciate 0
      08-16-2019, 05:59 AM   #8
chowser51
Major
chowser51's Avatar
United_States
510
Rep
1,047
Posts

Drives: 2018 BMW F33 430i xDrive
Join Date: Feb 2009
Location: Cleveland, OH

iTrader: (1)

Garage List
Delete iphone from car. Delete car from phone.
Update OS on phone. Punch your vin in bmw site to see if you need to update your firmware. If you do, grab a flash drive and do the update.

Reconnect everything and see if that fixes it.
Appreciate 1
clee1982478.00

      08-16-2019, 12:15 PM   #9
VirtualGuitars
Captain
VirtualGuitars's Avatar
United_States
554
Rep
861
Posts

Drives: 2019 BMW M550i xDrive Sedan
Join Date: Jan 2019
Location: Houston, TX

iTrader: (0)

Garage List
FYI, CarPlay gets updated through iOS updates.
__________________
2019 BMW M550i xDrive Sedan | 2018 BMW 230i Coupe | 2017 X6 BMW xDrive35i | 2011 BMW S1000RR (BMW Motorrad) | 2008 BMW 528i Sedan
Appreciate 0
      08-17-2019, 05:51 PM   #10
majedmiah
New Member
3
Rep
6
Posts

Drives: 2018 BMW 520d M Sport
Join Date: Aug 2019
Location: London

iTrader: (0)

I also have this issue, it seems if you don't have the Extended WiFi option then the connection seems to be very poor. I've got to keep the phone in the cup holder to get a decent connection and even then it's intermittent sometimes.

The gent I bought the coding option from to enable CarPlay explained that if I purchase a WiFi antenna that it can be installed and mitigate those connection problems.
Appreciate 0
      08-17-2019, 07:16 PM   #11
VirtualGuitars
Captain
VirtualGuitars's Avatar
United_States
554
Rep
861
Posts

Drives: 2019 BMW M550i xDrive Sedan
Join Date: Jan 2019
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by majedmiah View Post
I also have this issue, it seems if you don't have the Extended WiFi option then the connection seems to be very poor. I've got to keep the phone in the cup holder to get a decent connection and even then it's intermittent sometimes.

The gent I bought the coding option from to enable CarPlay explained that if I purchase a WiFi antenna that it can be installed and mitigate those connection problems.
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
__________________
2019 BMW M550i xDrive Sedan | 2018 BMW 230i Coupe | 2017 X6 BMW xDrive35i | 2011 BMW S1000RR (BMW Motorrad) | 2008 BMW 528i Sedan
Appreciate 1
clee1982478.00

      08-18-2019, 08:55 AM   #12
majedmiah
New Member
3
Rep
6
Posts

Drives: 2018 BMW 520d M Sport
Join Date: Aug 2019
Location: London

iTrader: (0)

Quote:
Originally Posted by VirtualGuitars View Post
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
I've purchased an antenna, if I were to plug it in behind the HU, will it work straight away or will it require additional coding?.
Appreciate 0
      08-19-2019, 07:03 PM   #13
M3nt4l
Private
19
Rep
61
Posts

Drives: BMW F20, BMW E91
Join Date: Feb 2019
Location: England

iTrader: (0)

Quote:
Originally Posted by majedmiah View Post
Quote:
Originally Posted by VirtualGuitars View Post
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
I've purchased an antenna, if I were to plug it in behind the HU, will it work straight away or will it require additional coding?.
Plug and play. Does not require additional coding
__________________
Vehicle Diagnostics and Coding
ISTA ESYS
CarPlay Activation
Sat Nav Map Updates
SLI FSC
Appreciate 0
      08-27-2019, 11:36 PM   #14
Reynolds230
New Member
Reynolds230's Avatar
Mauritius
3
Rep
8
Posts

Drives: BMW530E
Join Date: Apr 2018
Location: Mauritius

iTrader: (0)

Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by majedmiah View Post
Quote:
Originally Posted by VirtualGuitars View Post
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
I've purchased an antenna, if I were to plug it in behind the HU, will it work straight away or will it require additional coding?.
Plug and play. Does not require additional coding
I also want to install a wireless antenna on the head unit. Where can I find the explanations on how to access the unit and what to dismantle? Is anybody aware of a video posted for that? Thanks
Appreciate 0
      08-28-2019, 04:38 AM   #15
M3nt4l
Private
19
Rep
61
Posts

Drives: BMW F20, BMW E91
Join Date: Feb 2019
Location: England

iTrader: (0)

Quote:
Originally Posted by Reynolds230 View Post
Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by majedmiah View Post
Quote:
Originally Posted by VirtualGuitars View Post
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
I've purchased an antenna, if I were to plug it in behind the HU, will it work straight away or will it require additional coding?.
Plug and play. Does not require additional coding
I also want to install a wireless antenna on the head unit. Where can I find the explanations on how to access the unit and what to dismantle? Is anybody aware of a video posted for that? Thanks
What vehicle do you have?
__________________
Vehicle Diagnostics and Coding
ISTA ESYS
CarPlay Activation
Sat Nav Map Updates
SLI FSC
Appreciate 0
      08-28-2019, 11:40 AM   #16
Reynolds230
New Member
Reynolds230's Avatar
Mauritius
3
Rep
8
Posts

Drives: BMW530E
Join Date: Apr 2018
Location: Mauritius

iTrader: (0)

Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by Reynolds230 View Post
Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by majedmiah View Post
Quote:
Originally Posted by VirtualGuitars View Post
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
I've purchased an antenna, if I were to plug it in behind the HU, will it work straight away or will it require additional coding?.
Plug and play. Does not require additional coding
I also want to install a wireless antenna on the head unit. Where can I find the explanations on how to access the unit and what to dismantle? Is anybody aware of a video posted for that? Thanks
What vehicle do you have?
2018 530e
Appreciate 0
      08-28-2019, 01:55 PM   #17
M3nt4l
Private
19
Rep
61
Posts

Drives: BMW F20, BMW E91
Join Date: Feb 2019
Location: England

iTrader: (0)

Quote:
Originally Posted by Reynolds230 View Post
Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by Reynolds230 View Post
Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by majedmiah View Post
Quote:
Originally Posted by VirtualGuitars View Post
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
I've purchased an antenna, if I were to plug it in behind the HU, will it work straight away or will it require additional coding?.
Plug and play. Does not require additional coding
I also want to install a wireless antenna on the head unit. Where can I find the explanations on how to access the unit and what to dismantle? Is anybody aware of a video posted for that? Thanks
What vehicle do you have?
2018 530e
Remove passenger side cover where the airbag switch is) one screw which needs to be removed.

Then using a pry tool the trim panel (air vents and start stop button) will just pull out. I clip the wiring harnesses and put the trim panel to one side.

There will be two screws holding the climate control in remove them and then pry the unit from the bottom and it will pop out. I clip the wiring harness and put it to one side.

Then another two screws for the headunit itself. Unscrew then and pull the headunit forward. Plug in the WiFi Antenna in the WLAN port. Fix the antenna somewhere out the way.

Follow everything in reverse and it should be sorted.

The screws that are removed are TORX 20 or 25 I believe.

Any questions get in touch
__________________
Vehicle Diagnostics and Coding
ISTA ESYS
CarPlay Activation
Sat Nav Map Updates
SLI FSC
Appreciate 0
      08-28-2019, 02:14 PM   #18
Reynolds230
New Member
Reynolds230's Avatar
Mauritius
3
Rep
8
Posts

Drives: BMW530E
Join Date: Apr 2018
Location: Mauritius

iTrader: (0)

Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by Reynolds230 View Post
Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by Reynolds230 View Post
Quote:
Originally Posted by M3nt4l View Post
Quote:
Originally Posted by majedmiah View Post
Quote:
Originally Posted by VirtualGuitars View Post
Just for the record, any vehicle with CarPlay from the factory comes with the antenna. You really need to have it.
I've purchased an antenna, if I were to plug it in behind the HU, will it work straight away or will it require additional coding?.
Plug and play. Does not require additional coding
I also want to install a wireless antenna on the head unit. Where can I find the explanations on how to access the unit and what to dismantle? Is anybody aware of a video posted for that? Thanks
What vehicle do you have?
2018 530e
Remove passenger side cover where the airbag switch is) one screw which needs to be removed.

Then using a pry tool the trim panel (air vents and start stop button) will just pull out. I clip the wiring harnesses and put the trim panel to one side.

There will be two screws holding the climate control in remove them and then pry the unit from the bottom and it will pop out. I clip the wiring harness and put it to one side.

Then another two screws for the headunit itself. Unscrew then and pull the headunit forward. Plug in the WiFi Antenna in the WLAN port. Fix the antenna somewhere out the way.

Follow everything in reverse and it should be sorted.

The screws that are removed are TORX 20 or 25 I believe.

Any questions get in touch
Thank you very much. Appreciate.
Appreciate 0
      08-29-2019, 02:17 PM   #19
Magista
Registered
Magista's Avatar
Belgium
0
Rep
2
Posts

Drives: BMW G31 520d M-Sport
Join Date: Aug 2019
Location: Tournai

iTrader: (0)

Please, Do you have a sound alert for SMS / iMessages?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:39 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST