BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 5-Series (G30) Forum 2017+ BMW 5 Series (G30) General Discussions Bluetooth and iPhone X connectivity issues

Post Reply
 
Thread Tools Search this Thread
      10-09-2019, 03:28 PM   #1
georgere
Lieutenant Colonel
georgere's Avatar
United_States
502
Rep
1,871
Posts

Drives: 2016 M3 BSM
Join Date: Dec 2008
Location: Stamford CT

iTrader: (1)

Bluetooth and iPhone X connectivity issues

Often when I get into my car, the Bluetooth doesn't connect. So I get no CarPlay no phone nothing connected. Trying to connect from within the car fails to see the phone; trying to connect from within the phone does connect for a brief second but disconnect again.
My car is brand new 2020 model, my phone is iPhone X with latest updates always.
The problem been going on since I got the car. Sometimes it doesn't happen, other times it is happening every time I get in the car.
Re-pairing the phone to the car works flawlessly but is time consuming and weird to expect me do it when I did not have any such issues in may 10 year old 2005 e90.
Anyone experienced similar issues? Any fix?
__________________
My 1st love was 2006 BMW 325i Sport + Prem 6MT but I married the 2016 M3 BSM MDCT.
Appreciate 0
      10-09-2019, 05:27 PM   #2
LogicalApex
Private First Class
80
Rep
191
Posts

Drives: 2020 BMW 530xe
Join Date: Jul 2019
Location: USA

iTrader: (0)

I haven't had any issues on my 2020 530e with my iPhone X.

Are you on iOS 13.1.2? That's what I'm using.
Appreciate 0
      10-09-2019, 07:07 PM   #3
georgere
Lieutenant Colonel
georgere's Avatar
United_States
502
Rep
1,871
Posts

Drives: 2016 M3 BSM
Join Date: Dec 2008
Location: Stamford CT

iTrader: (1)

Quote:
Originally Posted by LogicalApex View Post
I haven't had any issues on my 2020 530e with my iPhone X.

Are you on iOS 13.1.2? That's what I'm using.
Yes, I am on latest software
__________________
My 1st love was 2006 BMW 325i Sport + Prem 6MT but I married the 2016 M3 BSM MDCT.
Appreciate 0
      10-10-2019, 08:11 AM   #4
VirtualGuitars
Captain
VirtualGuitars's Avatar
United_States
554
Rep
865
Posts

Drives: 2019 BMW M550i xDrive Sedan
Join Date: Jan 2019
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by georgere View Post
Quote:
Originally Posted by LogicalApex View Post
I haven't had any issues on my 2020 530e with my iPhone X.

Are you on iOS 13.1.2? That's what I'm using.
Yes, I am on latest software
Have you tried unpairing and repairing?
__________________
2019 BMW M550i xDrive Sedan | 2018 BMW 230i Coupe | 2017 X6 BMW xDrive35i | 2011 BMW S1000RR (BMW Motorrad) | 2008 BMW 528i Sedan
Appreciate 0
      10-10-2019, 02:36 PM   #5
ksoze
Major
ksoze's Avatar
United_States
313
Rep
1,123
Posts

Drives: 2018 M550iX
Join Date: Nov 2010
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by VirtualGuitars View Post
Have you tried unpairing and repairing?
VG - is yours working on current iOS? Assume you were on an iPhone.
__________________
2018 M550iX-Dinan Stage 1 | 2011 E93 M3 Convertible | 2002 E46 M3 Convertible | 2002 E53 X5 3.0 | 2000 E39 540i | 1998 E36 M3 | 1988 E28 M5 | 1987 E28 528i
Appreciate 0
      10-10-2019, 02:41 PM   #6
VirtualGuitars
Captain
VirtualGuitars's Avatar
United_States
554
Rep
865
Posts

Drives: 2019 BMW M550i xDrive Sedan
Join Date: Jan 2019
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by ksoze View Post
Quote:
Originally Posted by VirtualGuitars View Post
Have you tried unpairing and repairing?
VG - is yours working on current iOS? Assume you were on an iPhone.
Yes, I have an iPhone XS Max and have been running 13.1 since the very first developer beta. I'm actually on 13.2 Developer beta 2 now (which just came out today). No issues.
__________________
2019 BMW M550i xDrive Sedan | 2018 BMW 230i Coupe | 2017 X6 BMW xDrive35i | 2011 BMW S1000RR (BMW Motorrad) | 2008 BMW 528i Sedan
Appreciate 0
      10-10-2019, 03:12 PM   #7
964RS2014
Registered
0
Rep
4
Posts

Drives: Bmw530e
Join Date: Sep 2019
Location: Yorkshire

iTrader: (0)

I have the same issue with a Iphone and a 2020 car, sometimes it connects somethings it doesn’t. I have to delete the phone then reconnect
Appreciate 0
      10-10-2019, 04:02 PM   #8
hlothery
Seeking mental floss
294
Rep
510
Posts

Drives: 2019 M550iX
Join Date: May 2016
Location: San Antonio, Tx

iTrader: (0)

I have no issues with my iPhone Xr. But, I am not using carplay, just the BMW software.
__________________
_____________________________________________
Past rides: 2005 Mini Cooper S, 2007 Porsche Cayman, 2014 E350, 2016 M4 Convertible DCT
Appreciate 0
      10-10-2019, 07:21 PM   #9
530iDriver
Lieutenant Colonel
530iDriver's Avatar
United_States
994
Rep
1,685
Posts

Drives: 2017 BMW 530i
Join Date: May 2018
Location: Florida

iTrader: (0)

No issues with my iPhone X running iOS 13.

2017 530i.
__________________
2017 BMW 530i, Sport Line,Alpine White, Canberra Beige Sensatec, 19 inch V-Spoke wheels, basic plain Jane build with no options whatsoever..... "Less is more".

Before: 2011 BMW 328i E90 sedan, Platinum Bronze Metallic, Dakota Brown leather, 17 inch wheels, 6-speed auto, N52 6 Cyl inline N/A goodness....
Appreciate 0
      10-10-2019, 07:45 PM   #10
VirtualGuitars
Captain
VirtualGuitars's Avatar
United_States
554
Rep
865
Posts

Drives: 2019 BMW M550i xDrive Sedan
Join Date: Jan 2019
Location: Houston, TX

iTrader: (0)

Garage List
I take my previous post back. On occasion, I do have issues connecting to CarPlay. The only resolution I have found is wait until the next time you start the vehicle. Even though Bluetooth and Wi-Fi are showing connected to wireless CarPlay; I have had this issue a few times.
__________________
2019 BMW M550i xDrive Sedan | 2018 BMW 230i Coupe | 2017 X6 BMW xDrive35i | 2011 BMW S1000RR (BMW Motorrad) | 2008 BMW 528i Sedan
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:58 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST