BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 5-Series (G30) Forum Mechanical Maintenance - Break-in, Oil, Fluids, Servicing "Oil level above maximum" fault

Post Reply
 
Thread Tools Search this Thread
      09-19-2018, 05:38 PM   #1
ADS-UK
Captain
ADS-UK's Avatar
United Kingdom
445
Rep
978
Posts

Drives: G30 - 530d M Sport
Join Date: Feb 2014
Location: Edinburgh, Scotland

iTrader: (0)

Garage List
"Oil level above maximum" fault

Two days ago, I got an iDrive notification saying "Oil level above maximum". However, I didn't tip up oil or do anything to trigger it. BMW Assist ended up picking up the car as they didn't want me to drive around with it.

I got my car back today. Dealer is saying it's a faulty reading from a sensor and they've cleared the fault by recoding the car. Apparently sensor itself is not faulty. Has anyone else got this fault? What caused it?

Interestingly tow truck driver said, he's picked up quite a few BMWs with the same error in the last 6 months.
Attached Images
 
Appreciate 0
      12-09-2018, 06:43 PM   #2
zaidld
Registered
0
Rep
3
Posts

Drives: G30 530D M Sport
Join Date: Jul 2018
Location: England

iTrader: (0)

Had the same on mine, and dealer did the same thing and also charged the oil. Picked up the car with oil level set the mid point between min and max. BMW said they put 6 litres instead of 6.5. Three months later and my oil level is at max!
Appreciate 0
      12-10-2018, 09:27 AM   #3
ADS-UK
Captain
ADS-UK's Avatar
United Kingdom
445
Rep
978
Posts

Drives: G30 - 530d M Sport
Join Date: Feb 2014
Location: Edinburgh, Scotland

iTrader: (0)

Garage List
Quote:
Originally Posted by zaidld View Post
Had the same on mine, and dealer did the same thing and also charged the oil. Picked up the car with oil level set the mid point between min and max. BMW said they put 6 litres instead of 6.5. Three months later and my oil level is at max!
My guess is that this is a some sort of a sensor error that's becoming increasingly common. In my case they didn't even change oil.
Appreciate 0
      01-02-2019, 09:52 AM   #4
JohnEnglish
Private First Class
93
Rep
164
Posts

Drives: Black
Join Date: Jun 2018
Location: Earth

iTrader: (0)

I wonder if they use the same sensor as Audi as a bunch of new Audis have been experiencing the same issue. Only seems to happen in cooler weather. Audi has issued a TSB which involved replacing the oil level sensor.
Appreciate 0
      01-02-2019, 12:44 PM   #5
ADS-UK
Captain
ADS-UK's Avatar
United Kingdom
445
Rep
978
Posts

Drives: G30 - 530d M Sport
Join Date: Feb 2014
Location: Edinburgh, Scotland

iTrader: (0)

Garage List
Quote:
Originally Posted by JohnEnglish View Post
I wonder if they use the same sensor as Audi as a bunch of new Audis have been experiencing the same issue. Only seems to happen in cooler weather. Audi has issued a TSB which involved replacing the oil level sensor.
Quite possibly. Tow truck driver said to me that he's picked up a number of cars with the same fault.
Appreciate 0
      01-02-2019, 02:59 PM   #6
JohnEnglish
Private First Class
93
Rep
164
Posts

Drives: Black
Join Date: Jun 2018
Location: Earth

iTrader: (0)

Quote:
Originally Posted by ADS-UK View Post
Quite possibly. Tow truck driver said to me that he's picked up a number of cars with the same fault.
Sounds like a bad batch. I wonder if there was a design change or part supplier change. This is tech that's been around for a while. It's a bit odd to have so many failures across such a wide segment.
Appreciate 0
      05-29-2019, 04:57 PM   #7
PeterNZ
Registered
0
Rep
2
Posts

Drives: BMW530d xdrive
Join Date: May 2019
Location: Auckland

iTrader: (0)

The oil level above maximum certainly is an annoyance. I been to the garage twice for it to be rectified - oil has been changed, weighed and replaced twice with the answer that it must be a faulty sensor. This week it has started again after 7 months have ignored the warning for about 4 days this week and the warning has stopped with the oil returning to normal.

As someone else pointed out in the other thread it may have something to do with my driving habits the last month being all short trips - 11km twice daily with no long runs (I have being using my SUV to run out of town 300km/trip). Hopefully a long run will help clean the DPF and assist this oil problemůsounds like madness? Never had this problem with other cars.
Appreciate 0
      05-29-2019, 05:07 PM   #8
claykin
Brigadier General
United_States
474
Rep
3,075
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Curious if you tried closing the message then let the idrive measure oil level. I wonder if it would complain again or if it's a race condition / other bug causing the fault.

Seems BMW feels they addressed it in newer istep levels.
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      05-30-2019, 08:35 PM   #9
PeterNZ
Registered
0
Rep
2
Posts

Drives: BMW530d xdrive
Join Date: May 2019
Location: Auckland

iTrader: (0)

Quote:
Originally Posted by claykin View Post
Curious if you tried closing the message then let the idrive measure oil level. I wonder if it would complain again or if it's a race condition / other bug causing the fault.

Seems BMW feels they addressed it in newer istep levels.
Hi Claykin

thanks for your response

I measured the oil on level ground after a run last week and the sensors "reconfirmed" that the oil level was high. As noted above tho, the oil level alert has now gone away. I will remeasure the oil this weekend and see if it has miraculously got lower.

I have not added any oil to the system after the oil change at the dealership.

On start up I have been getting an alert (1), which disappears once the screen/computer has loaded, with no alerts (0) on the alert screen…
Appreciate 0
      06-13-2019, 12:27 PM   #10
CLABRO
THUNDER UP!
CLABRO's Avatar
United_States
252
Rep
291
Posts

Drives: BMW M Sport G30
Join Date: Apr 2017
Location: Tulsa, Oklahoma

iTrader: (1)

Garage List
Yeah, sounds like a faulty sensor. An annoyance for sure!
__________________

G30 l Alpine White l M Sport Package l Executive Tier l Icon Adaptive Full LED Headlights l Mocha Nappa Leather l Multi-Contour Seats l Drivers Assistance Package l Drivers Assistance Plus Package l Dynamic Handling Package l Parking Assistance Package l Bowers & Wilkins Diamond Surround Sound System l M Sport Brakes l Apple Carplay
Appreciate 0
      08-15-2019, 01:27 PM   #11
edit
New Member
0
Rep
6
Posts

Drives: 520xd G30
Join Date: Feb 2017
Location: bucuresti

iTrader: (0)

I had this fault too. What is funny is that this error came after 20.000km after I changed the oil...so oil if it fas too much, during that time of 11 months and 20.000km could only be burned down.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:36 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST