BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BIMMERPOST Universal Forums Site Related Announcements - Suggestions - Feedback - Questions Why is Bimmerpost so slow?

Post Reply
 
Thread Tools Search this Thread
      09-29-2019, 05:45 PM   #67
///M Power-Belgium
Lieutenant General
///M Power-Belgium's Avatar
Belgium
18492
Rep
11,191
Posts

Drives: ///M3-E92-DCT Silverstone II
Join Date: Jul 2012
Location: Belgium

iTrader: (0)

Quote:
Originally Posted by yco View Post
seems its fixed now.. and its great. !!!
I got this in the last 24 hours => *Error establishing a database connection*

But for the moment it seems to work better .
Bimmerpost may the force be with you !
__________________
BPM DEV-Tune & DCT Software-Tune & Servotronic & coding ///Alpine HID Angeleyes ///Oem.exhaust mod.
Appreciate 1
      09-29-2019, 06:52 PM   #68
Easy Listening
Registered
2
Rep
3
Posts

Drives: 2016 M4 Coupe
Join Date: Apr 2014
Location: Camas, WA

iTrader: (0)

If I were in charge of Bimmerpost's technical "infrastructure" and this is a problem approved to be solved with money, the first thing I'd do is get a second database server (a healthy-spec AWS RDB instance) and move half of the forums to it. It appears that everything currently lives on one box/instance, and that sucks for overall uptime. It's the ultimate single point of failure.

I did see VB debug info turned on during one of the maintenance periods, so the guys seem to be looking in the right places.
Appreciate 1
      09-29-2019, 07:11 PM   #69
Poiseuille
Colonel
Poiseuille's Avatar
United_States
3060
Rep
2,600
Posts

Drives: 2016 M4 DCT Tanzanite/Amaro
Join Date: Oct 2016
Location: Princeton

iTrader: (0)

you'll find lengthy discussion of recent BimmerPost performance failures on the Site Related subforum.
Appreciate 0
      09-29-2019, 07:13 PM   #70
premier3is
Private First Class
premier3is's Avatar
54
Rep
193
Posts

Drives: 2019 BMW 330i
Join Date: Jul 2019
Location: CA

iTrader: (0)

+1. App always seems to have connectivity issues and slowness with loading. It's my main way of interacting on the forum and it's been getting frustrating with the issues.
Appreciate 0
      09-30-2019, 01:37 AM   #71
Mikej0h
New Member
6
Rep
11
Posts

Drives: BMW 540i G30 2018
Join Date: Oct 2018
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by premier3is View Post
+1. App always seems to have connectivity issues and slowness with loading. It's my main way of interacting on the forum and it's been getting frustrating with the issues.
Exactly same here :
Appreciate 0
      09-30-2019, 06:24 PM   #72
RickFLM4
Brigadier General
RickFLM4's Avatar
United_States
3889
Rep
3,713
Posts

Drives: M4
Join Date: Jul 2015
Location: PB County, FL

iTrader: (0)

Down for hours again today. Hopefully this is not an indication of a permanent problem or end of Bimmerpost. Id have to come up with a whole new way to waste time when I should be working.
__________________
Current: 2018 SO/SS F83 ZCP
Gone: 2015 SO/SO F82
Appreciate 4
      09-30-2019, 06:29 PM   #73
F87source
Captain
F87source's Avatar
Canada
223
Rep
714
Posts

Drives: 2017 Bmw M2 6mt
Join Date: Aug 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by RickFLM4 View Post
Down for hours again today. Hopefully this is not an indication of a permanent problem or end of Bimmerpost. Id have to come up with a whole new way to waste time when I should be working.
Yeah it's crazy the site is going down more and more frequently for even longer periods of time now. Today it was down for something like 8 hours.
__________________
Follow me on Instagram @f87source
Appreciate 0
      09-30-2019, 07:04 PM   #74
NormanConquest
Colonel
1435
Rep
2,181
Posts

Drives: 340i
Join Date: May 2017
Location: Earth

iTrader: (0)

We want m3 performance from this site not 320i
Appreciate 1
      09-30-2019, 07:11 PM   #75
Captain Blood
Pirate and thief, avast
Captain Blood's Avatar
United_States
7838
Rep
10,066
Posts

Drives: 135i DCT
Join Date: May 2017
Location: Tortuga

iTrader: (0)

Garage List
2012 135  [5.00]
Quote:
Originally Posted by Poiseuille View Post
you'll find lengthy discussion of recent BimmerPost performance failures on the Site Related subforum.
That's what she said?
__________________
I am serious, and don't call me Shirley.
Appreciate 0
      10-01-2019, 11:09 AM   #76
Captain Blood
Pirate and thief, avast
Captain Blood's Avatar
United_States
7838
Rep
10,066
Posts

Drives: 135i DCT
Join Date: May 2017
Location: Tortuga

iTrader: (0)

Garage List
2012 135  [5.00]
The app is down for another 24-36 hours? New servers, or are admins fixing bugs? Just curious here.
Thanks!
__________________
I am serious, and don't call me Shirley.
Appreciate 0
      10-01-2019, 11:20 AM   #77
detroitm2
Major
detroitm2's Avatar
United_States
962
Rep
1,132
Posts

Drives: 2018 M2
Join Date: Aug 2018
Location: Michigan

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by Captain Blood View Post
The app is down for another 24-36 hours? New servers, or are admins fixing bugs? Just curious here.
Thanks!
Things seem faster today. I wonder if they did some hardware upgrades.

EDIT: Android app is working fine for me, FYI.
Appreciate 2
alex23641000.50

      10-01-2019, 11:28 AM   #78
Captain Blood
Pirate and thief, avast
Captain Blood's Avatar
United_States
7838
Rep
10,066
Posts

Drives: 135i DCT
Join Date: May 2017
Location: Tortuga

iTrader: (0)

Garage List
2012 135  [5.00]
Quote:
Originally Posted by detroitm2 View Post
Things seem faster today. I wonder if they did some hardware upgrades.

EDIT: Android app is working fine for me, FYI.
Its great on my computer, but I just got this laptop yesterday. I should fly through everything. I'm quite excited.......If only I could get my 135 headlights working like this.
__________________
I am serious, and don't call me Shirley.
Appreciate 0
      10-01-2019, 12:32 PM   #79
Explorerlyon
Private
60
Rep
93
Posts

Drives: Porsche 986 Acura TL-SHAWD BMW
Join Date: May 2019
Location: USA

iTrader: (0)

Forum was probably hacked. EVERY car forum I have been on over the past few years has been hacked. These are the exact same symptoms that occurred on every other forum as well. Notice that today, the forum is "Not Secure". I do recommend changing your password, logging out and staying logged out until its fixed.
Appreciate 0
      10-01-2019, 12:48 PM   #80
detroitm2
Major
detroitm2's Avatar
United_States
962
Rep
1,132
Posts

Drives: 2018 M2
Join Date: Aug 2018
Location: Michigan

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by Explorerlyon View Post
Forum was probably hacked. EVERY car forum I have been on over the past few years has been hacked. These are the exact same symptoms that occurred on every other forum as well. Notice that today, the forum is "Not Secure". I do recommend changing your password, logging out and staying logged out until its fixed.
Forum is secure from here. What sub-site are you accessing?

An invalid SSL certificate (for whatever reason) doesn't always mean theres an actual security concern.

EDIT: and Mark just posted an update about it (confirming my suspicions) https://f87.bimmerpost.com/forums/sh....php?t=1657067

Last edited by detroitm2; 10-01-2019 at 01:03 PM..
Appreciate 1
      10-01-2019, 01:13 PM   #81
nioh_lbbm2
Captain
417
Rep
693
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

Site is way faster today now on mobile and desktop. I'm glad Mark posted an update but it would still be nice to have some more transparency on issues that they're aware about and actively working on.


The app is once again finally usable from the time of this message!
Appreciate 0
      10-01-2019, 02:05 PM   #82
Explorerlyon
Private
60
Rep
93
Posts

Drives: Porsche 986 Acura TL-SHAWD BMW
Join Date: May 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by detroitm2 View Post
Forum is secure from here. What sub-site are you accessing?

An invalid SSL certificate (for whatever reason) doesn't always mean theres an actual security concern.

EDIT: and Mark just posted an update about it (confirming my suspicions) https://f87.bimmerpost.com/forums/sh....php?t=1657067
ALL of E90 is not secure, every sub forum. No, it doesn't mean it is un-secure, but the pattern here follows exactly the same pattern in other online forums:

1. Traffic on the site is slow, users start to notice.
2. Site is taken down for 1-2 days.
3. No security certificate
4. Management is updating hardware
5. 1-2 months later, everyone get a notice to change their password due to a breach of info.

I am simply pointing out to be careful with your user info and take note of the pattern. This is a great forum and anything online has issues from time to time.
Appreciate 1
      10-01-2019, 04:40 PM   #83
G35POPPEDMYCHERRY
Colonel
G35POPPEDMYCHERRY's Avatar
No_Country
2007
Rep
2,413
Posts

Drives: Totaled Toyota Celica :((
Join Date: Dec 2015
Location: Trenton, NJ

iTrader: (0)

seems like bimmerpost needs to be reflashed to stock; with updated iStep
Appreciate 0
      10-01-2019, 04:57 PM   #84
Captain Blood
Pirate and thief, avast
Captain Blood's Avatar
United_States
7838
Rep
10,066
Posts

Drives: 135i DCT
Join Date: May 2017
Location: Tortuga

iTrader: (0)

Garage List
2012 135  [5.00]
Quote:
Originally Posted by detroitm2 View Post
Forum is secure from here. What sub-site are you accessing?

An invalid SSL certificate (for whatever reason) doesn't always mean theres an actual security concern.

EDIT: and Mark just posted an update about it (confirming my suspicions) https://f87.bimmerpost.com/forums/sh....php?t=1657067
Thanks for the link! The app had me logged out and when I put in my name and password, they were rejected repeatedly.
__________________
I am serious, and don't call me Shirley.
Appreciate 0
      10-01-2019, 04:59 PM   #85
detroitm2
Major
detroitm2's Avatar
United_States
962
Rep
1,132
Posts

Drives: 2018 M2
Join Date: Aug 2018
Location: Michigan

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by Explorerlyon View Post
ALL of E90 is not secure, every sub forum. No, it doesn't mean it is un-secure, but the pattern here follows exactly the same pattern in other online forums:

1. Traffic on the site is slow, users start to notice.
2. Site is taken down for 1-2 days.
3. No security certificate
4. Management is updating hardware
5. 1-2 months later, everyone get a notice to change their password due to a breach of info.

I am simply pointing out to be careful with your user info and take note of the pattern. This is a great forum and anything online has issues from time to time.
Sure, but there is a security certificate. It just doesn't include the SAN for e90post.com.

If someone managed to gain access to the servers hosting this site, and wanted to leach all the password/PII data from it, they wouldn't need weeks to do it, and they could certainly do it without slowing down the site.

Theres no need to spread FUD on what amounts to (probably) a simple capacity issue.

you should always be careful with your personal information. Theres plenty of information (both right and wrong) about how to safeguard yourself. Probably the biggest lesson everyone learns too late is, never use the same password twice.
Appreciate 0
      10-01-2019, 05:03 PM   #86
detroitm2
Major
detroitm2's Avatar
United_States
962
Rep
1,132
Posts

Drives: 2018 M2
Join Date: Aug 2018
Location: Michigan

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by Captain Blood View Post
Thanks for the link! The app had me logged out and when I put in my name and password, they were rejected repeatedly.
My guess is your login info was rejected due to the SSL certificate being invalid. Pretty much all libraries that are used to make HTTP requests have a special flag to allow "bad" SSL certificates.. Its almost never a good idea to enable it. I'm guessing the app has that disabled.

Probably also explains why some of us are having zero issues, the SSL cert has the domains for several of the bimmerpost sub-sites, but not all of them.

Cheers
Appreciate 1
      10-01-2019, 06:19 PM   #87
Explorerlyon
Private
60
Rep
93
Posts

Drives: Porsche 986 Acura TL-SHAWD BMW
Join Date: May 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by detroitm2 View Post
Sure, but there is a security certificate. It just doesn't include the SAN for e90post.com.

If someone managed to gain access to the servers hosting this site, and wanted to leach all the password/PII data from it, they wouldn't need weeks to do it, and they could certainly do it without slowing down the site.

Theres no need to spread FUD on what amounts to (probably) a simple capacity issue.

you should always be careful with your personal information. Theres plenty of information (both right and wrong) about how to safeguard yourself. Probably the biggest lesson everyone learns too late is, never use the same password twice.
Yep, we don't know what happened and may never. I am simply stating the fact pattern as seen on several other car forum sites when they were hacked. They ALL had the exact pattern I described and so far this site is on track with as well. Usually when a site is going to update their hardware and take the site down, they plan that and announce it ahead of time.
Appreciate 0
      10-01-2019, 06:26 PM   #88
Jason
Administrator
Jason's Avatar
United_States
22686
Rep
19,851
Posts

Drives: F80 M3
Join Date: Mar 2005
Location: USA

iTrader: (0)

There's been no breach of security/data. Simply updating hardware and making things fast again. Any certificate issues are being sorted.
__________________
Check on the Latest BMW News
Become a fan of Bimmerpost Facebook
Follow us on Bimmerpost Twitter
Subscribe to Bimmerpost Youtube Channel
Appreciate 5
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:29 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST