BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 5-Series (G30) Forum iDrive, Audio, Bluetooth, Phone, Cameras, Electronics + Coding 2019 540i can't code start/stop

Post Reply
 
Thread Tools Search this Thread
      08-19-2019, 10:51 AM   #1
LuvMyE92
Occasionally frequent poster
LuvMyE92's Avatar
United_States
256
Rep
794
Posts

Drives: M2
Join Date: Jan 2008
Location: Cary, NC, USA

iTrader: (0)

2019 540i can't code start/stop

I have the BimmerCode app, which I updated and loaded the latest data, and everything works fine except that in the Engine ECU where we can set the start/stop to remember last setting, the update fails.

I presume that BMW is locking us out of this, since it's one of those annoying EPA regulations. My 2018 M2 had no such problem, so I'm guessing this was a new change for 2019.

Anyone with a 2019 or 2020 had luck setting this option?
__________________
F87 (mine)
E90 (hers)
G30 (ours)
Appreciate 0
      08-19-2019, 01:09 PM   #2
claykin
Brigadier General
United_States
508
Rep
3,164
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Quote:
Originally Posted by LuvMyE92 View Post
I have the BimmerCode app, which I updated and loaded the latest data, and everything works fine except that in the Engine ECU where we can set the start/stop to remember last setting, the update fails.

I presume that BMW is locking us out of this, since it's one of those annoying EPA regulations. My 2018 M2 had no such problem, so I'm guessing this was a new change for 2019.

Anyone with a 2019 or 2020 had luck setting this option?

Have you tried reporting this failure to the Bimmercode app developer? Could simply be a bug. Or could be a change BMW made in newer i-step levels.

Just confirming you are using one of the approved bluetooth ODBII dongles for the G series cars such as the Obdlink MX+?
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      08-19-2019, 02:33 PM   #3
LuvMyE92
Occasionally frequent poster
LuvMyE92's Avatar
United_States
256
Rep
794
Posts

Drives: M2
Join Date: Jan 2008
Location: Cary, NC, USA

iTrader: (0)

Quote:
Originally Posted by claykin View Post
Have you tried reporting this failure to the Bimmercode app developer? Could simply be a bug. Or could be a change BMW made in newer i-step levels.

Just confirming you are using one of the approved bluetooth ODBII dongles for the G series cars such as the Obdlink MX+?
I have not reported it to the developer. Not a bad idea.

I don't know if my dongle is approved, it was one recommended by BimmerCode when I bought it a couple of years ago. All of the other coding functions worked.
__________________
F87 (mine)
E90 (hers)
G30 (ours)
Appreciate 0
      08-19-2019, 02:40 PM   #4
claykin
Brigadier General
United_States
508
Rep
3,164
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Quote:
Originally Posted by LuvMyE92 View Post
Quote:
Originally Posted by claykin View Post
Have you tried reporting this failure to the Bimmercode app developer? Could simply be a bug. Or could be a change BMW made in newer i-step levels.

Just confirming you are using one of the approved bluetooth ODBII dongles for the G series cars such as the Obdlink MX+?
I have not reported it to the developer. Not a bad idea.

I don't know if my dongle is approved, it was one recommended by BimmerCode when I bought it a couple of years ago. All of the other coding functions worked.
Some coding options require a new(er) dongle. The one I mentioned above is the preferred dongle for US customers. There's another approved one which is more readily available in Europe.

Check the BimmerCode website for details. This may be the source of your issue.
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      08-19-2019, 03:19 PM   #5
VirtualGuitars
Captain
VirtualGuitars's Avatar
United_States
588
Rep
926
Posts

Drives: 2019 BMW M550i xDrive Sedan
Join Date: Jan 2019
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by LuvMyE92 View Post
I have the BimmerCode app, which I updated and loaded the latest data, and everything works fine except that in the Engine ECU where we can set the start/stop to remember last setting, the update fails.

I presume that BMW is locking us out of this, since it's one of those annoying EPA regulations. My 2018 M2 had no such problem, so I'm guessing this was a new change for 2019.

Anyone with a 2019 or 2020 had luck setting this option?
Make sure your engine is not running when you perform this coding update; otherwise it will fail. This is the only module that requires the engine to be off.
__________________
2019 BMW M550i xDrive Sedan | 2018 BMW 230i Coupe | 2017 X6 BMW xDrive35i | 2011 BMW S1000RR (BMW Motorrad) | 2008 BMW 528i Sedan
Appreciate 3
clee1982513.50
claykin508.00
LuvMyE92255.50

      08-20-2019, 07:02 AM   #6
LuvMyE92
Occasionally frequent poster
LuvMyE92's Avatar
United_States
256
Rep
794
Posts

Drives: M2
Join Date: Jan 2008
Location: Cary, NC, USA

iTrader: (0)

Quote:
Originally Posted by VirtualGuitars View Post
Make sure your engine is not running when you perform this coding update; otherwise it will fail. This is the only module that requires the engine to be off.
Ah ha! Thanks. That's also what Stephen (the developer) told me in his email yesterday: "the engine must not be running when trying to code this. Please enable diagnostic mode only."

That's pressing start/stop three times, with no foot on brake pedal, right?
__________________
F87 (mine)
E90 (hers)
G30 (ours)
Appreciate 2
      08-20-2019, 05:35 PM   #7
CLABRO
THUNDER UP!
CLABRO's Avatar
United_States
252
Rep
292
Posts

Drives: BMW M Sport G30
Join Date: Apr 2017
Location: Tulsa, Oklahoma

iTrader: (1)

Garage List
Quote:
Originally Posted by LuvMyE92 View Post
Ah ha! Thanks. That's also what Stephen (the developer) told me in his email yesterday: "the engine must not be running when trying to code this. Please enable diagnostic mode only."

That's pressing start/stop three times, with no foot on brake pedal, right?
Correct.
__________________

G30 l Alpine White l M Sport Package l Executive Tier l Icon Adaptive Full LED Headlights l Mocha Nappa Leather l Multi-Contour Seats l Drivers Assistance Package l Drivers Assistance Plus Package l Dynamic Handling Package l Parking Assistance Package l Bowers & Wilkins Diamond Surround Sound System l M Sport Brakes l Apple Carplay
Appreciate 0
      08-22-2019, 07:26 AM   #8
LuvMyE92
Occasionally frequent poster
LuvMyE92's Avatar
United_States
256
Rep
794
Posts

Drives: M2
Join Date: Jan 2008
Location: Cary, NC, USA

iTrader: (0)

Following the instructions as described above, I had no difficulties coding this option last night.

Thanks everyone!
__________________
F87 (mine)
E90 (hers)
G30 (ours)
Appreciate 1
clee1982513.50

      08-22-2019, 05:15 PM   #9
VirtualGuitars
Captain
VirtualGuitars's Avatar
United_States
588
Rep
926
Posts

Drives: 2019 BMW M550i xDrive Sedan
Join Date: Jan 2019
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by LuvMyE92 View Post
Following the instructions as described above, I had no difficulties coding this option last night.

Thanks everyone!
Glad we could help. For what's it's worth, I had the same issue early on!
__________________
2019 BMW M550i xDrive Sedan | 2018 BMW 230i Coupe | 2017 X6 BMW xDrive35i | 2011 BMW S1000RR (BMW Motorrad) | 2008 BMW 528i Sedan
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:12 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST