BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 5-Series (G30) Forum 2017+ BMW 5 Series (G30) General Discussions weird occurance

Post Reply
 
Thread Tools Search this Thread
      01-29-2020, 10:27 AM   #1
SteveinArizona
Colonel
United_States
1273
Rep
2,100
Posts

Drives: BMW 530e
Join Date: Jul 2016
Location: Greater Phoenix

iTrader: (0)

weird occurance

Yesterday I got in my car and started driving and realized that the steering wheel was still in the raised position blocking my view of the HUD. So I tried to use the control switch to move it and it wouldn't move. I even tried shutting off the car and starting it up again and it still didn't move.

I decided I had to call my SA the next day for a fix. But this morning, when I started the car, it worked fine.

Probably just a gremlin at work but wondering if anyone else had a similar issue.

Steve
Appreciate 0
      01-29-2020, 07:16 PM   #2
claykin
Brigadier General
United_States
559
Rep
3,304
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Quote:
Originally Posted by SteveinArizona View Post
Yesterday I got in my car and started driving and realized that the steering wheel was still in the raised position blocking my view of the HUD. So I tried to use the control switch to move it and it wouldn't move. I even tried shutting off the car and starting it up again and it still didn't move.

I decided I had to call my SA the next day for a fix. But this morning, when I started the car, it worked fine.

Probably just a gremlin at work but wondering if anyone else had a similar issue.

Steve
More than likely can be fixed with an iStep upgrade. My guess is dealer will try to update before taking a wrench to the car.
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      01-30-2020, 07:37 AM   #3
SteveinArizona
Colonel
United_States
1273
Rep
2,100
Posts

Drives: BMW 530e
Join Date: Jul 2016
Location: Greater Phoenix

iTrader: (0)

Quote:
Originally Posted by claykin View Post
More than likely can be fixed with an iStep upgrade. My guess is dealer will try to update before taking a wrench to the car.
Fixed itself. Worked fine all day yesterday. I am going to chalk it up to a random gremlin unless it repeats.

Thanks.

Steve
Appreciate 0
      01-30-2020, 07:57 AM   #4
miner42
Private First Class
43
Rep
110
Posts

Drives: 2018 540i
Join Date: Mar 2019
Location: Texas

iTrader: (0)

Same SteveinAZ on Polk site?
__________________
2018 540i
Imperial Blue/Cognac
Appreciate 0
      01-30-2020, 10:13 AM   #5
SteveinArizona
Colonel
United_States
1273
Rep
2,100
Posts

Drives: BMW 530e
Join Date: Jul 2016
Location: Greater Phoenix

iTrader: (0)

Quote:
Originally Posted by miner42 View Post
Same SteveinAZ on Polk site?
Not as far as I know unless "Polk site" is a term for something else.
Appreciate 0
      01-31-2020, 07:15 AM   #6
miner42
Private First Class
43
Rep
110
Posts

Drives: 2018 540i
Join Date: Mar 2019
Location: Texas

iTrader: (0)

Polk Audio - just a coincidence I suppose.
__________________
2018 540i
Imperial Blue/Cognac
Appreciate 0
      02-01-2020, 05:16 PM   #7
DBO
Second Lieutenant
Australia
93
Rep
232
Posts

Drives: G30 540i SDrive (MPPSK|BMS)
Join Date: Dec 2017
Location: Brisvegas

iTrader: (0)

I had exact same thing happen late last year on me. The electric adjust wasn't working at all. Tried a full shut-down on the side of the road, turned things on/off several times .. all to no avail. I ended up driving home with the wheel in the full up position (very awkward).

Next morning I had full intentions of taking it to the dealer - but.. all fixed again. Car must've done a full reset once it went to sleep for the night. I haven't had it happen since. I just had my 2nd year service done and asked them to check fault logs. All they mentioned was that they reset the fault codes, but they couldn't find any actual faults ..

I suspect a software bug. I think there's some secret key combo to get the car to do a full reboot. Must look into that for next time because I suspect it'll come up again at some stage.
Appreciate 1
clee1982646.00

      02-01-2020, 07:58 PM   #8
///M-er-gized
Captain
///M-er-gized's Avatar
United_States
649
Rep
652
Posts

Drives: 2019 540i
Join Date: Mar 2015
Location: Florida

iTrader: (0)

I had one weird occurrence too. Although mine was very different.

One day after work I started the car to drive home, and HUD wasn't working. It was just off. Also, when I started the car, the sound system was set to a satellite station I never ever listened to before. It definitely wasn't set to what I was listening to when I drove to work. Weird.

Also, I know someone is going to suggest either I had HUD turned off or I was wearing polarized sun glasses. Neither of those are true. HUD was turned on; I verified that, and I wasn't wearing sunglasses.

Later that evening, I went out to run a quick errand, and everything was back to normal.
__________________
2019 540i | Black Sapphire | Black Dakota Leather with Blue Stitching | M Sport Package | Executive Tier | Driver Assistance | Parking Assistance | HK | M Sport Brakes | Leather Dashboard
2016 M3 | YMB | Black Extended Merino | CF Roof | CF Trim | DCT | Adaptive | Executive
Appreciate 0
      02-02-2020, 06:35 AM   #9
Walesy
24 cans in a case, 24 hours in a day Hmmmmmm
Walesy's Avatar
Scotland
61
Rep
1,129
Posts

Drives: BMW G30 MSport
Join Date: Jul 2009
Location: Glasgow

iTrader: (1)

Mine did this, dealer replaced the control/memory module as it logged a fault.
__________________
2013 - 2017 F30 320D Sport
Present: G30 MSport - And love it!!
Appreciate 0
      02-02-2020, 08:04 AM   #10
SteveinArizona
Colonel
United_States
1273
Rep
2,100
Posts

Drives: BMW 530e
Join Date: Jul 2016
Location: Greater Phoenix

iTrader: (0)

Thanks everyone. All of this proves why putting everything on a touch screen tablet is a bad idea for cars. Not only does it force you to take your eyes off the road but these types of electronics do tend to have gremlins, occasionally reboot, etc. If that happens, everything goes (e.g., a Tesla Model 2).
Appreciate 0
      02-04-2020, 09:29 AM   #11
b74heavy
Alpine White|19" Wheels|Premium Package
b74heavy's Avatar
United_States
14
Rep
43
Posts

Drives: 2019 BMW 540I
Join Date: Aug 2018
Location: Alabama

iTrader: (0)

Quote:
Originally Posted by DBO View Post
I had exact same thing happen late last year on me. The electric adjust wasn't working at all. Tried a full shut-down on the side of the road, turned things on/off several times .. all to no avail. I ended up driving home with the wheel in the full up position (very awkward).

Next morning I had full intentions of taking it to the dealer - but.. all fixed again. Car must've done a full reset once it went to sleep for the night. I haven't had it happen since. I just had my 2nd year service done and asked them to check fault logs. All they mentioned was that they reset the fault codes, but they couldn't find any actual faults ..

I suspect a software bug. I think there's some secret key combo to get the car to do a full reboot. Must look into that for next time because I suspect it'll come up again at some stage.
I'm no expert but; I had the same issue once but I didn't try to adjust using the switch on the steering column. I shut down the car and started it up and it worked fine. I opened the door on the car and was moving stuff in so the door was open for 5 minutes or more. I think somehow if you don't get in and start it up right away it turns off the auto steering wheel positioning. It also turns off the garage door switch on the mirror. Also if you get this try turning off your car and locking it for at least 5 minutes so the computer completely shuts down then try again by getting in and starting it up immediately. See if that helps with the steering wheel auto positioning. As far as shutting the car down once you turn off engine, press down on the volume button and hold it for a few seconds and that will turn off all the displays. But there is a timer built in that turns off all electrical components after 5 minutes. Then the car is completely shutdown. How do I know about the 5 minutes. I was thinking of getting a Dash Cam and I wanted to see how long the usb ports stayed active. So I put my cell phone in a USB port and turned off the car. I watched the charging indicatior on the cell phone and it quit charging after 5 minutes or so. Why did I do this? Because I am retired and have no hobbies.
Appreciate 1
      02-04-2020, 09:52 AM   #12
SteveinArizona
Colonel
United_States
1273
Rep
2,100
Posts

Drives: BMW 530e
Join Date: Jul 2016
Location: Greater Phoenix

iTrader: (0)

Quote:
Originally Posted by b74heavy View Post
I'm no expert but; I had the same issue once but I didn't try to adjust using the switch on the steering column. I shut down the car and started it up and it worked fine. I opened the door on the car and was moving stuff in so the door was open for 5 minutes or more. I think somehow if you don't get in and start it up right away it turns off the auto steering wheel positioning. It also turns off the garage door switch on the mirror. Also if you get this try turning off your car and locking it for at least 5 minutes so the computer completely shuts down then try again by getting in and starting it up immediately. See if that helps with the steering wheel auto positioning. As far as shutting the car down once you turn off engine, press down on the volume button and hold it for a few seconds and that will turn off all the displays. But there is a timer built in that turns off all electrical components after 5 minutes. Then the car is completely shutdown. How do I know about the 5 minutes. I was thinking of getting a Dash Cam and I wanted to see how long the usb ports stayed active. So I put my cell phone in a USB port and turned off the car. I watched the charging indicatior on the cell phone and it quit charging after 5 minutes or so. Why did I do this? Because I am retired and have no hobbies.
Appreciate 0
      02-04-2020, 02:22 PM   #13
hlothery
Seeking mental floss
326
Rep
595
Posts

Drives: 2019 M550iX
Join Date: May 2016
Location: San Antonio, Tx

iTrader: (0)

Quote:
Originally Posted by SteveinArizona View Post
Seriously!!!!!
__________________
_____________________________________________
Past rides: 2005 Mini Cooper S, 2007 Porsche Cayman, 2014 E350, 2016 M4 Convertible DCT
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:57 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST