BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 5-Series (G30) Forum Mechanical Maintenance - Break-in, Oil, Fluids, Servicing We never seen that!

Post Reply
 
Thread Tools Search this Thread
      12-01-2019, 11:44 AM   #1
b74heavy
New Member
3
Rep
10
Posts

Drives: BMW 540I
Join Date: Aug 2018
Location: Alabama

iTrader: (0)

We never seen that!

Not what you want to hear from a BMW SA. My 540i has an electronic display for the speedometer and tachometer. I started up the car and the display had moved to the left about 1 1/2 inches. It was also very dim. The left part of the speedometer that was now covered up by the movement was on the right side of the display. I had a heads up display which was unaffected so I could at least see how fast I was going on the way home. I don't need any more tickets. I took a movie of it so I could show the service department since I am still under warranty. Thanks Apple. When I showed him the movie he said I have never seen anything like that. After about 3 drive cycles the display returned to normal.
Appreciate 0
      12-01-2019, 12:41 PM   #2
claykin
Brigadier General
United_States
508
Rep
3,168
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

This is not a new issue. Some earlier G30 builds, I believe mostly 2018 in US, have a connection issue that can manifest over time. I recall the solution is to replace the digital cluster. Or you simply need a software update.

Here's the bulletin.

https://static.nhtsa.gov/odi/tsbs/20...45344-9999.pdf
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      12-01-2019, 08:55 PM   #3
b74heavy
New Member
3
Rep
10
Posts

Drives: BMW 540I
Join Date: Aug 2018
Location: Alabama

iTrader: (0)

Quote:
Originally Posted by claykin View Post
This is not a new issue. Some earlier G30 builds, I believe mostly 2018 in US, have a connection issue that can manifest over time. I recall the solution is to replace the digital cluster. Or you simply need a software update.

Here's the bulletin.

https://static.nhtsa.gov/odi/tsbs/20...45344-9999.pdf
Thank you sir for the information. I have a 2019 540i but I don't know what the build date is so they will probably just install the software. I also have a issue with my Shutters and the CEL. This both the CEL and the Speedometer moving started a few days after they did the recall safety notice concerning the back up camera. I lost all my station presets and other things I cannot remember. I think it might be connected to the update of the software for the camera. Is there anywhere I can get the FSB's for my G-30? I had a M3 that the dealership couldn't fix and I had to show a copy of the FSB I got from a forum and show them what to fix. That also concerned the CEL. It was an M3 with bad ignition coils. They changed a lot of things that didn't help. New Coils fixed the problem.
Appreciate 0
      12-01-2019, 09:10 PM   #4
claykin
Brigadier General
United_States
508
Rep
3,168
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Quote:
Originally Posted by b74heavy View Post
Quote:
Originally Posted by claykin View Post
This is not a new issue. Some earlier G30 builds, I believe mostly 2018 in US, have a connection issue that can manifest over time. I recall the solution is to replace the digital cluster. Or you simply need a software update.

Here's the bulletin.

https://static.nhtsa.gov/odi/tsbs/20...45344-9999.pdf
Thank you sir for the information. I have a 2019 540i but I don't know what the build date is so they will probably just install the software. I also have a issue with my Shutters and the CEL. This both the CEL and the Speedometer moving started a few days after they did the recall safety notice concerning the back up camera. I lost all my station presets and other things I cannot remember. I think it might be connected to the update of the software for the camera. Is there anywhere I can get the FSB's for my G-30? I had a M3 that the dealership couldn't fix and I had to show a copy of the FSB I got from a forum and show them what to fix. That also concerned the CEL. It was an M3 with bad ignition coils. They changed a lot of things that didn't help. New Coils fixed the problem.
Early 2019s were affected so check build date in your drivers door jamb.

BTW, not terribly uncommon for software updates to fix issues and break things that were previously working OK. I need mine done, for same backup camera recall, but I was told to hold off and wait for a future ISTA version that will hopefully be more stable.

This is one of the easier sites to get TSBs. I assume this is what you mean, as I'm not sure what FSB means.

https://www.aboutautomobile.com/Tech...rvice-Bulletin
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      12-03-2019, 08:56 AM   #5
b74heavy
New Member
3
Rep
10
Posts

Drives: BMW 540I
Join Date: Aug 2018
Location: Alabama

iTrader: (0)

Thanks for the info. I wish I had waited to get the camera update. They did give me a brand new X5 to drive with 60 miles on it until my 540i is fixed.
Appreciate 0
      12-08-2019, 06:30 PM   #6
b74heavy
New Member
3
Rep
10
Posts

Drives: BMW 540I
Join Date: Aug 2018
Location: Alabama

iTrader: (0)

Just to update the dealer replaced my speedometer and tach displays reprogrammed the boxes and everything is working correctly now. They were able to change the display without leaving any marks or scratches.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:21 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST